Differences

This shows you the differences between two versions of the page.

Link to this comparison view

freebsd:security_update [2010/01/12 13:29] (current)
Line 1: Line 1:
 +Vous vous dites ce mec la parano comme il est il nous a forcemment trouve un outil pour les advisories de FreeBSD.
 +
 +Et bien c'est pas faux ! Pour toi public j'ai trouvé un outil qui se nomme freebsd-update
 +
 +Ce petit outil qui n'est en fait qu'un simple script shell permettant de recuperer la liste des advisories et de mettre à jour son systeme. ​
 +
 +Allez on l'​installe ​
 +<​code>​
 +# cd /​usr/​ports/​security/​freebsd-update
 +# make install clean 
 +</​code>​
 +Voila par défaut freebsd-update est installé dans /​usr/​local/​sbin et son fichier de configuration se trouve dans /​usr/​local/​etc/​ . Il faut d'​ailleurs le renommer
 +<​code>​
 +# mv /​usr/​local/​etc/​freebsd-update.conf-sample /​usr/​local/​etc/​freebsd-update.conf
 +</​code>​
 +Voyons ce que ça fait :
 +<​code>​
 +# freebsd-update fetch 
 +Fetching public key...
 +Fetching updates signature...
 +Fetching updates...
 +Fetching hash list signature...
 +Fetching hash list...
 +Examining local system...
 +Fetching updates...
 +/​boot/​kernel/​kernel...
 +/​lib/​libcrypto.so.3...
 +/​usr/​bin/​cvs...
 +/​usr/​include/​krb5-protos.h...
 +/​usr/​include/​netinet/​ip6.h...
 +/​usr/​include/​netinet/​tcp_var.h...
 +/​usr/​include/​openssl/​opensslv.h...
 +/​usr/​lib/​libcrypto.a...
 +/​usr/​lib/​libcrypto_p.a...
 +/​usr/​lib/​libkrb5.a...
 +/​usr/​lib/​libkrb5.so.7...
 +/​usr/​lib/​libkrb5_p.a...
 +/​usr/​lib/​libssl.a...
 +/​usr/​lib/​libssl.so.3...
 +/​usr/​lib/​libssl_p.a...
 +/​usr/​libexec/​kdc...
 +/​usr/​share/​man/​man8/​kdc.8.gz...
 +Updates fetched
 +
 +To install these updates, run: '/​usr/​local/​sbin/​freebsd-update install'​
 +
 +Don't forget to rebuild any statically linked ports
 +to use the updated libraries after you install them.
 +</​code>​
 +et après pour installer les binaires à jour 
 +<​code>​
 +# freebsd-update install
 +</​code>​
 +Il est à noté que les versions < 1.4 de freebsd-update ne sont pas capable de gerer les systèmes FreeBSD n'​utilisant pas les binaires officiels (par exemple si vous avez tout recompilé à la main). Ce point est réglé dans la version 1.5 de freebsd-update (version actuelle présente dans les ports) ​
 +
 +Voila public si tu veux en savoir plus je te laisse consulter les man pages 
 +<​code>​
 +# man freebsd-update
 +# man freebsd-update.conf
 +</​code>​
 +
 +aflab
 +
 +aflab@gcu-squad.org
 +
 +BUGfr parce que je le vaux bien ! (tm) http://​www.bug-fr.org
 +
  
freebsd/security_update.txt · Last modified: 2010/01/12 13:29 (external edit)