Imaginez que vous voulez installer la dernière version de xyz depuis les sources sur votre Debian. Vous lancez le ./configure et là… BLAM !!! Vous vous mangez tout plein d'erreurs à cause de librairies à la {#^@[{#@^ qui ne sont pas là. Et bien ceci n'arrivera plus, grâce à ce petit utilitaire très convivial qui s'appelle auto-apt. Pour l'installer, un apt-get install auto-apt suffit. Ensuite, à vous les joies des ./configure sans erreur. Pour cela, juste saisir auto-apt run ./configure à la place. C'est tout. Si apt détecte une erreur due à un fichier manquant, il vous proposera gentiment de l'installer pour vous.

Veillez juste à nourrir ses bases de données régulièrement avec des auto-apt update, auto-apt updatedb et auto-apt update-local.

Note : en fait, auto-apt marche avec toute commande qui pourrait avoir besoin de fichiers manquants : auto-apt run command.

linux/debian_auto-apt.txt · Last modified: 2010/01/12 13:29 (external edit)