Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revision Previous revision
Next revision
Previous revision
netbsd:pkgin_pour_garder_ton_gin [2009/11/27 09:38]
dzen
netbsd:pkgin_pour_garder_ton_gin [2010/01/12 13:29] (current)
Line 53: Line 53:
 zsh-4.3.9: adding /​usr/​pkg/​bin/​zsh to /etc/shells zsh-4.3.9: adding /​usr/​pkg/​bin/​zsh to /etc/shells
 </​code>​ </​code>​
 +
 +===== Supprimer des packages =====
 +
 +En fait, on me dit dans l'​oreillette 'ouais screen c'est vieux, tmux c'est mieux'
 +Soit, 3 coups de cuillère à pot:
 +
 +<​code>​
 +kenny# pkgin in tmux-1.0 ​                                                      
 +calculating dependencies for tmux-1.0...
 +nothing to upgrade.
 +2 packages to be installed: ncurses-5.7nb3 tmux-1.0 (1300K to download, 6136K to install)
 +proceed ? [y/N] y
 +</​code>​
 +et la Yummy! ca gère les dépendances en fait!
 +
 +maintenant, on vire screen:
 +
 +<​code>​
 +kenny# pkgin remove screen
 +1 packages to delete: screen-4.0.3nb2
 +proceed ? [y/N] y
 +</​code>​
 +===== Mettre à jour =====
 +
 +commençons par mettre à jour la base de package:
 +<​code>​
 +kenny# pkgin up
 +database for ftp://​ftp.netbsd.org/​pub/​pkgsrc/​packages/​NetBSD/​i386/​5.0/​All is up-to-date
 +</​code>​
 +
 +et mettons tout à jour:
 +<​code>​
 +kenny# pkgin fug
 +calculating dependencies for ncurses-5.7nb3...
 +calculating dependencies for pkgin-0.2.5...
 +calculating dependencies for sqlite3-3.6.17...
 +calculating dependencies for tmux-1.0...
 +calculating dependencies for zsh-4.3.9...
 +nothing to do.
 +</​code>​
 +
 +C'​était une petite intro à pkgin
 +
  
  
netbsd/pkgin_pour_garder_ton_gin.txt · Last modified: 2010/01/12 13:29 (external edit)